Error on Initialization

Oct 17, 2011 at 6:19 AM

Hi,


I am getting following error while accessing the tool.


An exception occurred during the operation, making the result invalid.  Check InnerException for exception details.
 at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()   at CRM.Tools.ODataQueryDesigner.CrmSdk.ExecuteCompletedEventArgs.get_Result()   at CRM.Tools.ODataQueryDesigner.Readers.MetadataReader.ExecuteRetrieveEntities_ExecuteCompleted(Object sender, ExecuteCompletedEventArgs response)   at CRM.Tools.ODataQueryDesigner.CrmSdk.OrganizationServiceClient.OnExecuteCompleted(Object state)


I tired accessing by server name and as well as by server IP, issue is still the same.

Regards,

Atul

Coordinator
Oct 17, 2011 at 12:52 PM

Hi Atul, there are a couple of people on here that have experienced the same issue and so far it seems to be the url used. I see that you have tried anumber of variations and ideally it shouldn't be this hard. I may need to take a look at the code to see if I can smooth things out to prevent this annoyance,

Are you trying this on a vanilla install of CRM 2011 with a fresh organisation or do you have customisations? Have you tried to run the app against a freah organisation? I'm curious to see if something is different to my test environment.

Thanks,

Rhett

 

Oct 17, 2011 at 1:48 PM

Hi Rhett,

No,i have not tried the app with fresh organisation. i am using the app with my previous org. which already contains customisations.

 

Thanks,

Atul

 

 

Coordinator
Oct 17, 2011 at 11:13 PM

Please download the latest version 1.0.0.4 and if an error occurs again please copy/paste the entire error message for me please.

Thank you

Oct 18, 2011 at 7:53 AM

Thanks Rhett,

The latest version works absolutely fine.

 

Thanks a lot  again

 

Regards,

Atul